libsndfile -- heap-based buffer overflow

2009-06-13T00:00:00
ID DSA-1814
Type debian
Reporter Debian
Modified 2009-06-13T00:00:00

Description

Two vulnerabilities have been found in libsndfile, a library to read and write sampled audio data. The Common Vulnerabilities and Exposures project identified the following problems:

Tobias Klein discovered that the VOC parsing routines suffer of a heap-based buffer overflow which can be triggered by an attacker via a crafted VOC header.

The vendor discovered that the AIFF parsing routines suffer of a heap-based buffer overflow similar to CVE-2009-1788 which can be triggered by an attacker via a crafted AIFF header.

In both cases the overflowing data is not completely attacker controlled but still leads to application crashes or under some circumstances might still lead to arbitrary code execution.

For the oldstable distribution (etch), this problem has been fixed in version 1.0.16-2+etch2.

For the stable distribution (lenny), this problem has been fixed in version 1.0.17-4+lenny2.

For the testing distribution (squeeze), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in version 1.0.20-1.

We recommend that you upgrade your libsndfile packages.