ghostscript -- several vulnerabilities

2009-03-20T00:00:00
ID DSA-1746
Type debian
Reporter Debian
Modified 2009-03-20T00:00:00

Description

Two security issues have been discovered in ghostscript, the GPL Ghostscript PostScript/PDF interpreter. The Common Vulnerabilities and Exposures project identifies the following problems:

Jan Lieskovsky discovered multiple integer overflows in the ICC library, which allow the execution of arbitrary code via crafted ICC profiles in PostScript files with embedded images.

Jan Lieskovsky discovered insufficient upper-bounds checks on certain variable sizes in the ICC library, which allow the execution of arbitrary code via crafted ICC profiles in PostScript files with embedded images.

For the stable distribution (lenny), these problems have been fixed in version 8.62.dfsg.1-3.2lenny1.

For the oldstable distribution (etch), these problems have been fixed in version 8.54.dfsg.1-5etch2. Please note that the package in oldstable is called gs-gpl.

For the testing distribution (squeeze) and the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your ghostscript/gs-gpl packages.