libpam-heimdal -- programming error

2009-02-11T00:00:00
ID DSA-1722
Type debian
Reporter Debian
Modified 2009-02-11T00:00:00

Description

Derek Chan discovered that the PAM module for the Heimdal Kerberos implementation allows reinitialisation of user credentials when run from a setuid context, resulting in potential local denial of service by overwriting the credential cache file or to local privilege escalation.

For the stable distribution (etch), this problem has been fixed in version 2.5-1etch1.

For the upcoming stable distribution (lenny), this problem has been fixed in version 3.10-2.1.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your libpam-heimdal package.