cupsys -- integer overflow

2008-12-02T00:00:00
ID DSA-1677
Type debian
Reporter Debian
Modified 2008-12-02T00:00:00

Description

An integer overflow has been discovered in the image validation code of cupsys, the Common UNIX Printing System. An attacker could trigger this bug by supplying a malicious graphic that could lead to the execution of arbitrary code.

For the stable distribution (etch) this problem has been fixed in version 1.2.7-4etch6.

For testing distribution (lenny) this issue will be fixed soon.

For the unstable distribution (sid) this problem has been fixed in version 1.3.8-1lenny4.

We recommend that you upgrade your cupsys packages.