libxml2 -- buffer overflow

2008-10-14T00:00:00
ID DSA-1654
Type debian
Reporter Debian
Modified 2008-10-14T00:00:00

Description

It was discovered that libxml2, the GNOME XML library, didn't correctly handle long entity names. This could allow the execution of arbitrary code via a malicious XML file.

For the stable distribution (etch), this problem has been fixed in version 2.6.27.dfsg-5.

For the unstable distribution (sid), this problem has been fixed in version 2.6.32.dfsg-4.

We recommend that you upgrade your libxml2 package.