squid -- programming error

2008-02-05T00:00:00
ID DSA-1482
Type debian
Reporter Debian
Modified 2008-02-05T00:00:00

Description

It was discovered that malformed cache update replies against the Squid WWW proxy cache could lead to the exhaustion of system memory, resulting in potential denial of service.

For the old stable distribution (sarge), the update cannot currently be processed on the buildd security network due to a bug in the archive management script. This will be resolved soon. An update for i386 is temporarily available at <https://people.debian.org/~jmm/squid/>.

For the stable distribution (etch), this problem has been fixed in version 2.6.5-6etch1.

We recommend that you upgrade your squid packages.