exiv2 -- integer overflow

2008-01-23T00:00:00
ID DSA-1474
Type debian
Reporter Debian
Modified 2008-01-23T00:00:00

Description

Meder Kydyraliev discovered an integer overflow in the thumbnail handling of libexif, the EXIF/IPTC metadata manipulation library, which could result in the execution of arbitrary code.

The old stable distribution (sarge) doesn't contain exiv2 packages.

For the stable distribution (etch), this problem has been fixed in version 0.10-1.5.

We recommend that you upgrade your exiv2 packages.