librpcsecgss -- buffer overflow

2007-10-15T00:00:00
ID DSA-1387
Type debian
Reporter Debian
Modified 2007-10-15T00:00:00

Description

It has been discovered that the original patch for a buffer overflow in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (CVE-2007-3999, DSA-1368-1) was insufficient to protect from arbitrary code execution in some environments.

The old stable distribution (sarge) does not contain a librpcsecgss package.

For the stable distribution (etch), this problem has been fixed in version 0.14-2etch3.

For the unstable distribution (sid), this problem has been fixed in version 0.14-4.

We recommend that you upgrade your librpcsecgss package.