postgresql-7.4 -- programming error

2007-06-17T00:00:00
ID DSA-1311
Type debian
Reporter Debian
Modified 2007-06-17T00:00:00

Description

It was discovered that the PostgreSQL database performs insufficient validation of variables passed to privileged SQL statement called security definers, which could lead to SQL privilege escalation.

For the oldstable distribution (sarge) this problem has been fixed in version 7.4.7-6sarge5. A powerpc build is not yet available due to problems with the build host. It will be provided later.

For the stable distribution (etch) this problem has been fixed in version 7.4.17-0etch1.

For the unstable distribution (sid) this problem has been fixed in version 7.4.17-1.

We recommend that you upgrade your PostgreSQL packages.