libexif -- integer overflow

2007-06-16T00:00:00
ID DSA-1310
Type debian
Reporter Debian
Modified 2007-06-16T00:00:00

Description

A vulnerability has been discovered in libexif, a library to parse EXIF files, which allows denial of service and possible execution of arbitrary code via malformed EXIF data.

For the old-stable distribution (sarge), this problem has been fixed in version 0.6.9-6sarge1.

For the stable distribution (etch), this problem has been fixed in version 0.6.13-5etch1.

We recommend that you upgrade your libexif package.