evince -- buffer overflow

2006-12-28T00:00:00
ID DSA-1243
Type debian
Reporter Debian
Modified 2006-12-28T00:00:00

Description

Renaud Lifchitz discovered that gv, the PostScript and PDF viewer for X, performs insufficient boundary checks in the Postscript parsing code, which allows the execution of arbitrary code through a buffer overflow. Evince embeds a copy of gv and needs an update as well.

For the stable distribution (sarge) this problem has been fixed in version 0.1.5-2sarge1.

For the upcoming stable distribution (etch) this problem has been fixed in version 0.4.0-3.

For the unstable distribution (sid) this problem has been fixed in version 0.4.0-3.

We recommend that you upgrade your evince package.