libextractor -- buffer overflow

2006-05-29T00:00:00
ID DSA-1081
Type debian
Reporter Debian
Modified 2006-05-29T00:00:00

Description

Luigi Auriemma discovered a buffer overflow in the processing of ASF files in libextractor, a library to extract arbitrary meta-data from files, which can lead to the execution of arbitrary code.

The old stable distribution (woody) is not affected by this problem.

For the stable distribution (sarge) this problem has been fixed in version 0.4.2-2sarge5.

For the unstable distribution (sid) this problem has been fixed in version 0.5.14-1.

We recommend that you upgrade your libextractor packages.