horde2 -- several vulnerabilities

2006-04-14T00:00:00
ID DSA-1034
Type debian
Reporter Debian
Modified 2006-04-14T00:00:00

Description

Several remote vulnerabilities have been discovered in the Horde web application framework, which may lead to the execution of arbitrary web script code. The Common Vulnerabilities and Exposures project identifies the following problems:

Null characters in the URL parameter bypass a sanity check, which allowed remote attackers to read arbitrary files, which allowed information disclosure.

User input in the help viewer was passed unsanitised to the eval() function, which allowed injection of arbitrary web code.

The old stable distribution (woody) doesn't contain horde2 packages.

For the stable distribution (sarge) these problems have been fixed in version 2.2.8-1sarge2.

The unstable distribution (sid) does no longer contain horde2 packages.

We recommend that you upgrade your horde2 package.