mod-gnutls -- LTS security update

2015-03-14T00:00:00
ID DLA-170
Type debian
Reporter Debian
Modified 2015-03-14T00:00:00

Description

Thomas Klute discovered that in mod-gnutls, an Apache module providing SSL and TLS encryption with GnuTLS, a bug caused the server's client verify mode not to be considered at all, in case the directory's configuration was unset. Clients with invalid certificates were then able to leverage this flaw in order to get access to that directory.

For Debian 6 Squeeze, these issues have been fixed in mod-gnutls version 0.5.6-1+squeeze2