logo
DATABASE RESOURCES PRICING ABOUT US

[SECURITY] [DSA 4919-1] lz4 security update

Description

- ------------------------------------------------------------------------- Debian Security Advisory DSA-4919-1 security@debian.org https://www.debian.org/security/ Salvatore Bonaccorso May 21, 2021 https://www.debian.org/security/faq - ------------------------------------------------------------------------- Package : lz4 CVE ID : CVE-2021-3520 Debian Bug : 987856 Jasper Lievisse Adriaanse reported an integer overflow flaw in lz4, a fast LZ compression algorithm library, resulting in memory corruption. For the stable distribution (buster), this problem has been fixed in version 1.8.3-1+deb10u1. We recommend that you upgrade your lz4 packages. For the detailed security status of lz4 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/lz4 Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/ Mailing list: debian-security-announce@lists.debian.org


Affected Package


OS OS Version Package Name Package Version
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 9 liblz4-tool 0.0~r131-2+deb9u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 9 liblz4-dev 0.0~r131-2+deb9u1
Debian 9 liblz4-dev 0.0~r131-2+deb9u1
Debian 9 liblz4-tool 0.0~r131-2+deb9u1
Debian 9 liblz4-dev 0.0~r131-2+deb9u1
Debian 9 lz4 0.0~r131-2+deb9u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 9 liblz4-tool 0.0~r131-2+deb9u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 9 liblz4-tool 0.0~r131-2+deb9u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 9 liblz4-dev 0.0~r131-2+deb9u1
Debian 9 liblz4-1-dbg 0.0~r131-2+deb9u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 9 liblz4-1 0.0~r131-2+deb9u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 9 liblz4-1-dbg 0.0~r131-2+deb9u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 9 liblz4-1 0.0~r131-2+deb9u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 9 liblz4-tool 0.0~r131-2+deb9u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 9 liblz4-1-dbg 0.0~r131-2+deb9u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 9 liblz4-1-dbg 0.0~r131-2+deb9u1
Debian 9 liblz4-dev 0.0~r131-2+deb9u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-tool 1.8.3-1+deb10u1
Debian 9 liblz4-1 0.0~r131-2+deb9u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 9 liblz4-1 0.0~r131-2+deb9u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 liblz4-dev 1.8.3-1+deb10u1
Debian 10 lz4 1.8.3-1+deb10u1
Debian 9 liblz4-1 0.0~r131-2+deb9u1
Debian 10 liblz4-1 1.8.3-1+deb10u1
Debian 9 liblz4-1-dbg 0.0~r131-2+deb9u1
Debian 10 liblz4-1-dbgsym 1.8.3-1+deb10u1
Debian 10 lz4-dbgsym 1.8.3-1+deb10u1

Related