[SECURITY] [DSA 4859-1] libzstd security update

2021-02-20T08:21:27
ID DEBIAN:DSA-4859-1:F2BB7
Type debian
Reporter Debian
Modified 2021-02-20T08:21:27

Description


Debian Security Advisory DSA-4859-1 security@debian.org https://www.debian.org/security/ Sebastien Delafond February 20, 2021 https://www.debian.org/security/faq


Package : libzstd Debian Bug : 982519

It was discovered that zstd, a compression utility, was vulnerable to a race condition: it temporarily exposed, during a very short timeframe, a world-readable version of its input even if the original file had restrictive permissions.

For the stable distribution (buster), this problem has been fixed in version 1.3.8+dfsg-3+deb10u2.

We recommend that you upgrade your libzstd packages.

For the detailed security status of libzstd please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libzstd

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org