[SECURITY] [DSA 4300-1] libarchive-zip-perl security update

2018-09-22T14:02:19
ID DEBIAN:DSA-4300-1:62111
Type debian
Reporter Debian
Modified 2018-09-22T14:02:19

Description


Debian Security Advisory DSA-4300-1 security@debian.org https://www.debian.org/security/ Salvatore Bonaccorso September 22, 2018 https://www.debian.org/security/faq


Package : libarchive-zip-perl CVE ID : CVE-2018-10860 Debian Bug : 902882

It was discovered that Archive::Zip, a perl module for manipulation of ZIP archives, is prone to a directory traversal vulnerability. An attacker able to provide a specially crafted archive for processing can take advantage of this flaw to overwrite arbitrary files during archive extraction.

For the stable distribution (stretch), this problem has been fixed in version 1.59-1+deb9u1.

We recommend that you upgrade your libarchive-zip-perl packages.

For the detailed security status of libarchive-zip-perl please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libarchive-zip-perl

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org