[SECURITY] [DSA 4214-1] zookeeper security update

2018-06-01T21:23:33
ID DEBIAN:DSA-4214-1:A8500
Type debian
Reporter Debian
Modified 2018-06-01T21:23:33

Description


Debian Security Advisory DSA-4214-1 security@debian.org https://www.debian.org/security/ Moritz Muehlenhoff June 01, 2018 https://www.debian.org/security/faq


Package : zookeeper CVE ID : CVE-2018-8012

It was discovered that Zookeeper, a service for maintaining configuration information, enforced no authentication/authorisation when a server attempts to join a Zookeeper quorum.

This update backports authentication support. Additional configuration steps are needed, please see https://cwiki.apache.org/confluence/display/ZOOKEEPER/Server-Server+mutual+authentication for additional information.

For the oldstable distribution (jessie), this problem has been fixed in version 3.4.9-3+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 3.4.9-3+deb9u1.

We recommend that you upgrade your zookeeper packages.

For the detailed security status of zookeeper please refer to its security tracker page at: https://security-tracker.debian.org/tracker/zookeeper

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org