[SECURITY] [DSA 4211-1] xdg-utils security update

2018-05-25T21:02:26
ID DEBIAN:DSA-4211-1:9A3FC
Type debian
Reporter Debian
Modified 2018-05-25T21:02:26

Description


Debian Security Advisory DSA-4211-1 security@debian.org https://www.debian.org/security/ Luciano Bello May 25, 2018 https://www.debian.org/security/faq


Package : xdg-utils CVE ID : CVE-2017-18266 Debian Bug : 898317

Gabriel Corona discovered that xdg-utils, a set of tools for desktop environment integration, is vulnerable to argument injection attacks. If the environment variable BROWSER in the victim host has a "%s" and the victim opens a link crafted by an attacker with xdg-open, the malicious party could manipulate the parameters used by the browser when opened. This manipulation could set, for example, a proxy to which the network traffic could be intercepted for that particular execution.

For the oldstable distribution (jessie), this problem has been fixed in version 1.1.0~rc1+git20111210-7.4+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 1.1.1-1+deb9u1.

We recommend that you upgrade your xdg-utils packages.

For the detailed security status of xdg-utils please refer to its security tracker page at: https://security-tracker.debian.org/tracker/xdg-utils

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org