Lucene search

K
debianDebianDEBIAN:DSA-4114-1:C7344
HistoryFeb 15, 2018 - 7:04 a.m.

[SECURITY] [DSA 4114-1] jackson-databind security update

2018-02-1507:04:58
lists.debian.org
15

EPSS

0.14

Percentile

95.7%


Debian Security Advisory DSA-4114-1 [email protected]
https://www.debian.org/security/ Sebastien Delafond
February 15, 2018 https://www.debian.org/security/faq


Package : jackson-databind
CVE ID : CVE-2017-17485 CVE-2018-5968
Debian Bug : 888316 888318

It was discovered that jackson-databind, a Java library used to parse
JSON and other data formats, did not properly validate user input
before attempting deserialization. This allowed an attacker to perform
code execution by providing maliciously crafted input.

For the oldstable distribution (jessie), these problems have been fixed
in version 2.4.2-2+deb8u3.

For the stable distribution (stretch), these problems have been fixed in
version 2.8.6-1+deb9u3.

We recommend that you upgrade your jackson-databind packages.

For the detailed security status of jackson-databind please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/jackson-databind

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]