[SECURITY] [DSA 4093-1] openocd security update

2018-01-22T02:43:51
ID DEBIAN:DSA-4093-1:B89E9
Type debian
Reporter Debian
Modified 2018-01-22T02:43:51

Description


Debian Security Advisory DSA-4093-1 security@debian.org https://www.debian.org/security/
January 21, 2018 https://www.debian.org/security/faq


Package : openocd CVE ID : CVE-2018-5704 Debian Bug : 887488

Josef Gajdusek discovered that OpenOCD, a JTAG debugger for ARM and MIPS, was vulnerable to Cross Protocol Scripting attacks. An attacker could craft a HTML page that, when visited by a victim running OpenOCD, could execute arbitrary commands on the victims host.

This fix also sets the OpenOCD default binding to localhost, instead of every network interfaces. This can be changed with the added "bindto" command argument.

For the oldstable distribution (jessie), this problem has been fixed in version 0.8.0-4+deb7u1.

For the stable distribution (stretch), this problem has been fixed in version 0.9.0-1+deb8u1.

We recommend that you upgrade your openocd packages.

For the detailed security status of openocd please refer to its security tracker page at: https://security-tracker.debian.org/tracker/openocd

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org