[SECURITY] [DSA 4018-1] openssl security update

2017-11-03T23:23:45
ID DEBIAN:DSA-4018-1:01441
Type debian
Reporter Debian
Modified 2017-11-03T23:23:45

Description


Debian Security Advisory DSA-4018-1 security@debian.org https://www.debian.org/security/ Salvatore Bonaccorso November 04, 2017 https://www.debian.org/security/faq


Package : openssl CVE ID : CVE-2017-3735 CVE-2017-3736

Multiple vulnerabilities have been discovered in OpenSSL, a Secure Sockets Layer toolkit. The Common Vulnerabilities and Exposures project identifies the following issues:

CVE-2017-3735

It was discovered that OpenSSL is prone to a one-byte buffer
overread while parsing a malformed IPAddressFamily extension in an
X.509 certificate.

Details can be found in the upstream advisory:
https://www.openssl.org/news/secadv/20170828.txt

CVE-2017-3736

It was discovered that OpenSSL contains a carry propagation bug in
the x86_64 Montgomery squaring procedure.

Details can be found in the upstream advisory:
https://www.openssl.org/news/secadv/20171102.txt

For the oldstable distribution (jessie), CVE-2017-3735 has been fixed in version 1.0.1t-1+deb8u7. The oldstable distribution is not affected by CVE-2017-3736.

For the stable distribution (stretch), these problems have been fixed in version 1.1.0f-3+deb9u1.

For the unstable distribution (sid), these problems have been fixed in version 1.1.0g-1.

We recommend that you upgrade your openssl packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org