[SECURITY] [DSA 4008-1] wget security update

2017-10-28T14:36:23
ID DEBIAN:DSA-4008-1:604F8
Type debian
Reporter Debian
Modified 2017-10-28T14:36:23

Description


Debian Security Advisory DSA-4008-1 security@debian.org https://www.debian.org/security/ Moritz Muehlenhoff October 28, 2017 https://www.debian.org/security/faq


Package : wget CVE ID : CVE-2017-13089 CVE-2017-13090

Antti Levomaeki, Christian Jalio, Joonas Pihlaja and Juhani Eronen discovered two buffer overflows in the HTTP protocol handler of the Wget download tool, which could result in the execution of arbitrary code when connecting to a malicious HTTP server.

For the oldstable distribution (jessie), these problems have been fixed in version 1.16-1+deb8u4.

For the stable distribution (stretch), these problems have been fixed in version 1.18-5+deb9u1.

We recommend that you upgrade your wget packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org