[SECURITY] [DSA 4006-1] mupdf security update

2017-10-24T15:41:27
ID DEBIAN:DSA-4006-1:C4D54
Type debian
Reporter Debian
Modified 2017-10-24T15:41:27

Description


Debian Security Advisory DSA-4006-1 security@debian.org https://www.debian.org/security/
October 24, 2017 https://www.debian.org/security/faq


Package : mupdf CVE ID : CVE-2017-14685 CVE-2017-14686 CVE-2017-14687 CVE-2017-15587 Debian Bug : 877379 879055

Multiple vulnerabilities have been found in MuPDF, a PDF file viewer, which may result in denial of service or the execution of arbitrary code.

CVE-2017-14685, CVE-2017-14686, and CVE-2017-14687

 WangLin discovered that a crafted .xps file can crash MuPDF and
 potentially execute arbitrary code in several ways, since the
 application makes unchecked assumptions on the entry format.

CVE-2017-15587

Terry Chia and Jeremy Heng discovered an integer overflow that can
cause arbitrary code execution via a crafted .pdf file.

For the stable distribution (stretch), these problems have been fixed in version 1.9a+ds1-4+deb9u1.

We recommend that you upgrade your mupdf packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org