[SECURITY] [DSA 3877-1] tor security update

2017-06-10T05:19:55
ID DEBIAN:DSA-3877-1:4B239
Type debian
Reporter Debian
Modified 2017-06-10T05:19:55

Description


Debian Security Advisory DSA-3877-1 security@debian.org https://www.debian.org/security/ Salvatore Bonaccorso June 10, 2017 https://www.debian.org/security/faq


Package : tor CVE ID : CVE-2017-0376 Debian Bug : 864424

It has been discovered that Tor, a connection-based low-latency anonymous communication system, contain a flaw in the hidden service code when receiving a BEGIN_DIR cell on a hidden service rendezvous circuit. A remote attacker can take advantage of this flaw to cause a hidden service to crash with an assertion failure (TROVE-2017-005).

For the stable distribution (jessie), this problem has been fixed in version 0.2.5.14-1.

For the upcoming stable distribution (stretch), this problem will be fixed in version 0.2.9.11-1~deb9u1.

For the unstable distribution (sid), this problem has been fixed in version 0.2.9.11-1.

We recommend that you upgrade your tor packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org