[SECURITY] [DSA 2944-1] gnutls26 security update

2014-06-01T08:39:15
ID DEBIAN:DSA-2944-1:FD558
Type debian
Reporter Debian
Modified 2014-06-01T08:39:15

Description


Debian Security Advisory DSA-2944-1 security@debian.org http://www.debian.org/security/ Moritz Muehlenhoff June 01, 2014 http://www.debian.org/security/faq


Package : gnutls26 CVE ID : CVE-2014-3466

Joonas Kuorilehto discovered that GNU TLS performed insufficient validation of session IDs during TLS/SSL handshakes. A malicious server could use this to execute arbitrary code or perform denial or service.

For the stable distribution (wheezy), this problem has been fixed in version 2.12.20-8+deb7u2.

For the unstable distribution (sid), this problem has been fixed in version 2.12.23-16.

We recommend that you upgrade your gnutls26 packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org