[SECURITY] [DLA 930-1] libxstream-java security update

2017-05-01T08:58:14
ID DEBIAN:DLA-930-1:3C143
Type debian
Reporter Debian
Modified 2017-05-01T08:58:14

Description

Package : libxstream-java Version : 1.4.2-1+deb7u2 CVE ID : CVE-2017-7957 Debian Bug : #861521

It was discovered that there was a remote application crash vulnerability in libxstream-java, a Java library to serialize objects to XML and back again. This was due to mishandled attempts to create an instance of the primitive type 'void' during unmarshalling.

For Debian 7 "Wheezy", this issue has been fixed in libxstream-java version 1.4.2-1+deb7u2.

We recommend that you upgrade your libxstream-java packages.

Regards,


  ,''`.
 : :'  :     Chris Lamb
 `. `'`      lamby@debian.org / chris-lamb.co.uk
   `-