[SECURITY] [DLA 888-1] logback security update

2017-04-07T22:12:15
ID DEBIAN:DLA-888-1:6C29C
Type debian
Reporter Debian
Modified 2017-04-07T22:12:15

Description

Package : logback Version : 1:1.0.4-1+deb7u1 CVE ID : CVE-2017-5929 Debian Bug : 857343

It was discovered that logback, a flexible logging library for Java, would deserialize data from untrusted sockets which may lead to the execution of arbitrary code. This issue has been resolved by adding a whitelist to use only trusted classes.

For Debian 7 "Wheezy", these problems have been fixed in version 1:1.0.4-1+deb7u1.

We recommend that you upgrade your logback packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS