Lucene search

K
debianDebianDEBIAN:DLA-878-1:061B4
HistoryMar 28, 2017 - 8:21 p.m.

[SECURITY] [DLA 878-1] libytnef security update

2017-03-2820:21:27
lists.debian.org
10

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

7.5

Confidence

High

EPSS

0.003

Percentile

66.4%

Package : libytnef
Version : 1.5-4+deb7u1
CVE ID : CVE-2017-6298 CVE-2017-6299 CVE-2017-6300 CVE-2017-6301
CVE-2017-6302 CVE-2017-6303 CVE-2017-6304 CVE-2017-6305
CVE-2017-6801 CVE-2017-6802

CVE-2017-6298
Null Pointer Deref / calloc return value not checked

CVE-2017-6299
Infinite Loop / DoS in the TNEFFillMapi function in lib/ytnef.c

CVE-2017-6300
Buffer Overflow in version field in lib/tnef-types.h

CVE-2017-6301
Out of Bounds Reads

CVE-2017-6302
Integer Overflow

CVE-2017-6303
Invalid Write and Integer Overflow

CVE-2017-6304
Out of Bounds read

CVE-2017-6305
Out of Bounds read and write

CVE-2017-6801
Out-of-bounds access with fields of Size 0 in TNEFParse() in libytnef

CVE-2017-6802
Heap-based buffer over-read on incoming Compressed RTF Streams,
related to DecompressRTF() in libytnef

For Debian 7 "Wheezy", these problems have been fixed in version
1.5-4+deb7u1.

We recommend that you upgrade your libytnef packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

7.5

Confidence

High

EPSS

0.003

Percentile

66.4%