[SECURITY] [DLA 840-1] libplist security update

2017-02-28T14:52:46
ID DEBIAN:DLA-840-1:D5FE9
Type debian
Reporter Debian
Modified 2017-02-28T14:52:46

Description

Package : libplist Version : 1.8-1+deb7u2 CVE ID : CVE-2017-5834 CVE-2017-5835 Debian Bug : 854000

Several vulnerabilities were discovered in libplist, a library for reading and writing the Apple binary and XML property lists format. A maliciously crafted plist file could cause an application to crash by triggering a heap-based buffer overflow and memory allocation error in the plist_from_bin function.

For Debian 7 "Wheezy", these problems have been fixed in version 1.8-1+deb7u2.

We recommend that you upgrade your libplist packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS