[SECURITY] [DLA-774-1] postgresql-common security update

2017-01-01T18:54:35
ID DEBIAN:DLA-774-1:59337
Type debian
Reporter Debian
Modified 2017-01-01T18:54:35

Description

Package : postgresql-common Version : 134wheezy5

A security vulnerability and a data loss bug have been found in postgresql-common, Debian's PostgreSQL database cluster management tools.

CVE-2016-1255

Dawid Golunski discovered that a symlink in /var/log/postgresql/
could be used by the "postgres" system user to write to arbitrary
files on the filesystem the next time PostgreSQL is started by
root.

614374

Rafał Kupka discovered that pg_upgradecluster did not properly
upgrade databases that are owned by a non-login role (or group).

For Debian 7 "Wheezy", these problems have been fixed in version 134wheezy5.

We recommend that you upgrade your postgresql-common packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS