[SECURITY] [DLA 767-1] curl security update

2016-12-29T17:20:17
ID DEBIAN:DLA-767-1:B58F0
Type debian
Reporter Debian
Modified 2016-12-29T17:20:17

Description

Package : curl Version : 7.26.0-1+wheezy18 CVE ID : CVE-2016-9586 Debian Bug : 848958

It was discovered that libcurl's implementation of the printf() functions triggers a buffer overflow when doing a large floating point output. The bug occurs when the conversion outputs more than 255 bytes.

The flaw happens because the floating point conversion is using system functions without the correct boundary checks.

If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.

This flaw does not exist in the command line tool.

For Debian 7 "Wheezy", these problems have been fixed in version 7.26.0-1+wheezy18.

We recommend that you upgrade your curl packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS