[SECURITY] [DLA 528-1] libcommons-fileupload-java security update

2016-06-26T18:55:08
ID DEBIAN:DLA-528-1:BE307
Type debian
Reporter Debian
Modified 2016-06-26T18:55:08

Description

Package : libcommons-fileupload-java Version : 1.2.2-1+deb7u3 CVE ID : CVE-2016-3092

A denial of service vulnerability was identified in Commons FileUpload that occurred when the length of the multipart boundary was just below the size of the buffer (4096 bytes) used to read the uploaded file. This caused the file upload process to take several orders of magnitude longer than if the boundary was the typical tens of bytes long.

For Debian 7 "Wheezy", these problems have been fixed in version 1.2.2-1+deb7u3.

We recommend that you upgrade your libcommons-fileupload-java packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS