[SECURITY] [DLA 394-1] passenger security update

2016-01-18T19:00:23
ID DEBIAN:DLA-394-1:100B0
Type debian
Reporter Debian
Modified 2016-01-18T19:00:23

Description

Package : passenger Version : 2.2.11debian-2+deb6u1 CVE ID : CVE-2015-7519

agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.