Lucene search

K
debianDebianDEBIAN:DLA-3604-1:16926
HistoryOct 05, 2023 - 4:13 p.m.

[SECURITY] [DLA 3604-1] qemu security update

2023-10-0516:13:52
lists.debian.org
5
multiple vulnerabilities
processor emulator
qemu
use-after-free
heap buffer overflow
memory corruption
debian 10 buster
security update

8.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

8.1 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

5.1%


Debian LTS Advisory DLA-3604-1 [email protected]
https://www.debian.org/lts/security/ Sean Whitton
October 05, 2023 https://wiki.debian.org/LTS

Package : qemu
Version : 1:3.1+dfsg-8+deb10u11
CVE ID : CVE-2020-24165 CVE-2023-0330 CVE-2023-3180
Debian Bug : 1029155

Multiple issues were discovered in qemu, a fast processor emulator.

CVE-2020-24165

A use-after-free race in the code generator could lead to the
execution of arbitrary code.

CVE-2023-0330

A DMA-MMIO reentrancy problem in the lsi53c895a device may lead to
memory corruption bugs, such as stack overflow or use-after-free.

CVE-2023-3180

The function virtio_crypto_sym_op_helper, part of the implementation
of qemu's virtual crypto device, did not check that the values of
'src_len' and 'dst_len' are the same.  This could lead to a heap
buffer overflow.

For Debian 10 buster, these problems have been fixed in version
1:3.1+dfsg-8+deb10u11.

We recommend that you upgrade your qemu packages.

For the detailed security status of qemu please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/qemu

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS
Attachment:
signature.asc
Description: PGP signature

8.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

8.1 High

AI Score

Confidence

High

0.0004 Low

EPSS

Percentile

5.1%