Lucene search

K
debianDebianDEBIAN:DLA-3603-1:0FE4F
HistoryOct 05, 2023 - 11:09 a.m.

[SECURITY] [DLA 3603-1] libxpm security update

2023-10-0511:09:57
lists.debian.org
13
libxpm
out of bounds read
x pixmap
buffer overflow
denial of service
debian lts
debian 10 buster
security update
arbitrary code

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

AI Score

8.8

Confidence

High

EPSS

0

Percentile

5.1%


Debian LTS Advisory DLA-3603-1 [email protected]
https://www.debian.org/lts/security/ Emilio Pozuelo Monfort
October 05, 2023 https://wiki.debian.org/LTS


Package : libxpm
Version : 1:3.5.12-1+deb10u2
CVE ID : CVE-2023-43786 CVE-2023-43787 CVE-2023-43788 CVE-2023-43789

Several vulnerabilities were found in libXpm, the X Pixmap (XPM) image
library.

CVE-2023-43786

Yair Mizrahi discovered an infinite recursion issue when parsing
crafted XPM files, which would result in denial of service.

CVE-2023-43787

Yair Mizrahi discovered a buffer overflow vulnerability in libX11
when parsing crafted XPM files, which could result in denial of
service or potentially the execution of arbitrary code.

CVE-2023-43788

Alan Coopersmith found an out of bounds read in
XpmCreateXpmImageFromBuffer, which could result in denial of
service when parsing crafted XPM files.

CVE-2023-43789

Alan Coopersmith discovered an out of bounds read issue when
parsing corrupted colormaps, which could lead to denial of
service when parsing crafted XPM files.

For Debian 10 buster, these problems have been fixed in version
1:3.5.12-1+deb10u2.

We recommend that you upgrade your libxpm packages.

For the detailed security status of libxpm please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libxpm

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

AI Score

8.8

Confidence

High

EPSS

0

Percentile

5.1%