Lucene search

K
debianDebianDEBIAN:DLA-3526-1:E3E85
HistoryAug 13, 2023 - 4:32 p.m.

[SECURITY] [DLA 3526-1] libreoffice security update

2023-08-1316:32:01
lists.debian.org
8
cve-2023-0950
update
libreoffice
cve-2023-2255
vulnerabilities
office suite
buster
security
debian 10
cve-2022-3874

CVSS3

9.1

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

AI Score

7.3

Confidence

High

EPSS

0.001

Percentile

34.2%


Debian LTS Advisory DLA-3526-1 [email protected]
https://www.debian.org/lts/security/ Bastien Roucariès
August 13, 2023 https://wiki.debian.org/LTS


Package : libreoffice
Version : 1:6.1.5-3+deb10u10
CVE ID : CVE-2022-3874 CVE-2023-0950 CVE-2023-2255
Debian Bug :

LibreOffice an office productivity suite was affected by multiple
vulnerabilities.

CVE-2022-3874

Libreoffice may be configured to add an empty
entry to the Java class path.
This may lead to run arbitrary Java code from the
current directory.

CVE-2023-0950

Improper Validation of Array Index vulnerability in the
spreadsheet component allows an attacker to craft a
spreadsheet document that will cause an array index
underflow when loaded. In the affected versions of LibreOffice
certain malformed spreadsheet formulas, such as AGGREGATE,
could be created with less parameters passed to the formula
interpreter than it expected, leading to an array index
underflow, in which case there is a risk that arbitrary
code could be executed.

CVE-2023-2255

Improper access control in editor components of
LibreOffice allowed an attacker to craft
a document that would cause external links to be loaded without prompt.
In the affected versions of LibreOffice documents
that used "floating frames"
linked to external files, would load the contents of those frames
without prompting the user for permission to do so.
This was inconsistent with the treatment of other linked
content in LibreOffice.

For Debian 10 buster, these problems have been fixed in version
1:6.1.5-3+deb10u10.

We recommend that you upgrade your libreoffice packages.

For the detailed security status of libreoffice please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libreoffice

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

CVSS3

9.1

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

AI Score

7.3

Confidence

High

EPSS

0.001

Percentile

34.2%