[SECURITY] [DLA 2377-1] qt4-x11 security update

2020-09-28T07:00:26
ID DEBIAN:DLA-2377-1:093E0
Type debian
Reporter Debian
Modified 2020-09-28T07:00:26

Description


Debian LTS Advisory DLA-2377-1 debian-lts@lists.debian.org https://www.debian.org/lts/security/ Adrian Bunk September 21, 2020 https://wiki.debian.org/LTS


Package : qt4-x11 Version : 4:4.8.7+dfsg-11+deb9u1 CVE ID : CVE-2018-15518 CVE-2018-19869 CVE-2018-19870 CVE-2018-19871 CVE-2018-19872 CVE-2018-19873 CVE-2020-17507 Debian Bug : 923003 970308

Several vulnerabilities were fixed in qt4-x11, the legacy version of the Qt toolkit.

CVE-2018-15518

Double-free or corruption in QXmlStreamReader during parsing of a 
specially crafted illegal XML document.

CVE-2018-19869

A malformed SVG image causes a segmentation fault.

CVE-2018-19870

A malformed GIF image causes a NULL pointer dereference in 
QGifHandler resulting in a segmentation fault.

CVE-2018-19871

Uncontrolled Resource Consumption in QTgaFile.

CVE-2018-19872

A malformed PPM image causes a crash.

CVE-2018-19873

QBmpHandler segfault on malformed BMP file.

CVE-2020-17507

Buffer over-read in the XBM parser.

For Debian 9 stretch, these problems have been fixed in version 4:4.8.7+dfsg-11+deb9u1.

We recommend that you upgrade your qt4-x11 packages.

For the detailed security status of qt4-x11 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/qt4-x11

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS