[SECURITY] [DLA 2334-1] ruby-websocket-extensions security update

2020-08-19T12:01:46
ID DEBIAN:DLA-2334-1:71411
Type debian
Reporter Debian
Modified 2020-08-19T12:01:46

Description


Debian LTS Advisory DLA-2334-1 debian-lts@lists.debian.org https://www.debian.org/lts/security/ Chris Lamb August 19, 2020 https://wiki.debian.org/LTS


Package : ruby-websocket-extensions Version : 0.1.2-1+deb9u1 CVE ID : CVE-2020-7663 Debian Bug : #964274

It was discovered that there was a denial of service vulnerability in ruby-websocket-extensions, a library for managing long-lived HTTP "WebSocket" connections.

The parser took quadratic time when parsing a header containing an unclosed string parameter value whose content is a repeating two-byte sequence. This could be abused by an attacker to conduct a Regex Denial Of Service (ReDoS) on a single-threaded server by providing a malicious payload in the Sec-WebSocket-Extensions HTTP header.

For Debian 9 "Stretch", this problem has been fixed in version 0.1.2-1+deb9u1.

We recommend that you upgrade your ruby-websocket-extensions packages.

For the detailed security status of ruby-websocket-extensions please refer to its security tracker page at: https://security-tracker.debian.org/tracker/ruby-websocket-extensions

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS