[SECURITY] [DLA 2314-1] clamav security update

2020-08-06T05:58:00
ID DEBIAN:DLA-2314-1:B5354
Type debian
Reporter Debian
Modified 2020-08-06T05:58:00

Description


Debian LTS Advisory DLA-2314-1 debian-lts@lists.debian.org https://www.debian.org/lts/security/ Emilio Pozuelo Monfort August 06, 2020 https://wiki.debian.org/LTS


Package : clamav Version : 0.102.4+dfsg-0+deb9u1 CVE ID : CVE-2020-3327 CVE-2020-3350 CVE-2020-3481

Several vulnerabilities have been found in the ClamAV antivirus toolkit:

CVE-2020-3327

An out of bounds read in the ARJ archive-parsing module could cause
denial of service. The fix in 0.102.3 was incomplete.

CVE-2020-3350

A malicious user could trick clamscan, clamdscan or clamonacc into
moving or removing a different file than intended when those are
used with one of the --move or --remove options. This could be used
to get rid of special system files.

CVE-2020-3481

The EGG archive module was vulnerable to denial of service via NULL
pointer dereference due to improper error handling. The official
signature database avoided this problem because the signatures there
avoided the use of the EGG archive parser.

For Debian 9 stretch, these problems have been fixed in version 0.102.4+dfsg-0+deb9u1.

We recommend that you upgrade your clamav packages.

For the detailed security status of clamav please refer to its security tracker page at: https://security-tracker.debian.org/tracker/clamav

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS