[SECURITY] [DLA 2131-2] rrdtool regression update

2020-03-02T18:58:40
ID DEBIAN:DLA-2131-2:719C5
Type debian
Reporter Debian
Modified 2020-03-02T18:58:40

Description

Package : rrdtool Version : 1.4.8-1.2+deb8u2 CVE ID : CVE-2014-6262 Debian Bug : 952958

It was discovered that there was a regression in a previous fix, which resulted in the following error:

ERROR: cannot compile regular expression: Error while compiling regular expression ^(?:[^%]+|%%)%[+- 0#]?[0-9]([.][0-9]+)?leEfF%s(?:[^%]+|%%)$ at char 18: range out of order in character class (^(?:[^%]+|%%)%[+- 0#]?[0-9]([.][0-9]+)?leEfF%s(?:[^%]+|%%)$)

For Debian 8 "Jessie", this problem has been fixed in version 1.4.8-1.2+deb8u2.

We recommend that you upgrade your rrdtool packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS

Best, Utkarsh