[SECURITY] DLA-2066-1 gthumb security update

2020-01-14T09:03:09
ID DEBIAN:DLA-2066-1-:CF83D
Type debian
Reporter Debian
Modified 2020-01-14T09:03:09

Description

Package : gthumb Version : 3:3.3.1-2.1+deb8u2 CVE ID : CVE-2019-20326

A heap-based buffer overflow in _cairo_image_surface_create_from_jpeg() in extensions/cairo_io/cairo-image-surface-jpeg.c in gThumb and Pix allows attackers to cause a crash and potentially execute arbitrary code via a crafted JPEG file.

For Debian 8 "Jessie", this problem has been fixed in version 3:3.3.1-2.1+deb8u2.

We recommend that you upgrade your gthumb packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS