[SECURITY] [DLA 2020-1] libonig security update

2019-12-04T11:43:30
ID DEBIAN:DLA-2020-1:A1433
Type debian
Reporter Debian
Modified 2019-12-04T11:43:30

Description

Package : libonig Version : 5.9.5-3.2+deb8u4 CVE ID : CVE-2019-19012 CVE-2019-19204 CVE-2019-19246 Debian Bug : 944959 945313

Several vulnerabilities were discovered in the Oniguruma regular expressions library, notably used in PHP mbstring.

CVE-2019-19012

An integer overflow in the search_in_range function in regexec.c
leads to an out-of-bounds read, in which the offset of this read
is under the control of an attacker. (This only affects the 32-bit
compiled version). Remote attackers can cause a denial-of-service
or information disclosure, or possibly have unspecified other
impact, via a crafted regular expression.

CVE-2019-19204

In the function fetch_range_quantifier in regparse.c, PFETCH is
called without checking PEND. This leads to a heap-based buffer
over-read and lead to denial-of-service via a crafted regular
expression.

CVE-2019-19246

Heap-based buffer over-read in str_lower_case_match in regexec.c
can lead to denial-of-service via a crafted regular expression.

For Debian 8 "Jessie", these problems have been fixed in version 5.9.5-3.2+deb8u4.

We recommend that you upgrade your libonig packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS