[SECURITY] [DLA 1942-2] phpbb3 regression update

2019-10-07T07:24:14
ID DEBIAN:DLA-1942-2:93F4A
Type debian
Reporter Debian
Modified 2019-10-07T07:24:14

Description

This is a follow-up to DLA-1942-1.

There was some confusion about the correct fix for CVE-2019-13776.

The correct announcement for this DLA should have been:

Package : phpbb3 Version : 3.0.12-5+deb8u4 CVE ID : CVE-2019-13776 CVE-2019-16993

CVE-2019-16993

In phpBB, includes/acp/acp_bbcodes.php had improper verification of a CSRF token on the BBCode page in the Administration Control Panel. An actual CSRF attack was possible if an attacker also managed to retrieve the session id of a reauthenticated administrator prior to targeting them.

CVE-2019-13776

phpBB allowed the stealing of an Administration Control Panel session id by leveraging CSRF in the Remote Avatar feature. The CSRF Token Hijacking lead to stored XSS.

For Debian 8 "Jessie", these problems have been fixed in version 3.0.12-5+deb8u4.

We recommend that you upgrade your phpbb3 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS