[SECURITY] [DLA 1835-2] python3.4 regression update

2019-06-25T15:04:32
ID DEBIAN:DLA-1835-2:87B43
Type debian
Reporter Debian
Modified 2019-06-25T15:04:32

Description

Package : python3.4 Version : 3.4.2-1+deb8u4 CVE ID : CVE-2019-9740 CVE-2019-9947 Debian Bug : 931044

The update issued as DLA-1835-1 caused a regression in the http.client library in Python 3.4 which was broken by the patch intended to fix CVE-2019-9740 and CVE-2019-9947.

For Debian 8 "Jessie", this problem has been fixed in version 3.4.2-1+deb8u4.

We recommend that you upgrade your python3.4 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS