[SECURITY] [DLA 1827-1] gvfs security update

2019-06-19T21:49:36
ID DEBIAN:DLA-1827-1:BFEC5
Type debian
Reporter Debian
Modified 2019-06-19T21:49:36

Description

Package : gvfs Version : 1.22.2-1+deb8u1 CVE ID : CVE-2019-12795 Debian Bug : 930376

Simon McVittie discovered a flaw in gvfs, the Gnome Virtual File System. The gvfsd daemon opened a private D-Bus server socket without configuring an authorization rule. A local attacker could connect to this server socket and issue D-Bus method calls.

(Note that the server socket only accepts a single connection, so the attacker would have to discover the server and connect to the socket before its owner does.)

For Debian 8 "Jessie", this problem has been fixed in version 1.22.2-1+deb8u1.

We recommend that you upgrade your gvfs packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS