[SECURITY] [DLA 1691-1] exiv2 security update

2019-02-26T21:20:29
ID DEBIAN:DLA-1691-1:A00E2
Type debian
Reporter Debian
Modified 2019-02-26T21:20:29

Description

From: Thorsten Alteholz <debian@alteholz.de> To: debian-lts-announce@lists.debian.org Subject: [SECURITY] [DLA 1691-1] exiv2 security update

Package : exiv2 Version : 0.24-4.1+deb8u3 CVE ID : CVE-2018-17581 CVE-2018-19107 CVE-2018-19108 CVE-2018-19535 CVE-2018-20097

Several issues have been found in exiv2, a EXIF/IPTC/XMP metadata manipulation tool.

CVE-2018-17581 A stack overflow due to a recursive function call causing excessive stack consumption which leads to denial of service.

CVE-2018-19107 A heap based buffer over-read caused by an integer overflow could result in a denial of service via a crafted file.

CVE-2018-19108 There seems to be an infinite loop inside a function that can be activated by a crafted image.

CVE-2018-19535 A heap based buffer over-read caused could result in a denial of service via a crafted file.

CVE-2018-20097 A crafted image could result in a denial of service.

For Debian 8 "Jessie", these problems have been fixed in version 0.24-4.1+deb8u3.

We recommend that you upgrade your exiv2 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS