[SECURITY] [DLA 1614-1] openjpeg2 security update

2018-12-22T13:57:35
ID DEBIAN:DLA-1614-1:4971C
Type debian
Reporter Debian
Modified 2018-12-22T13:57:35

Description

Package : openjpeg2 Version : 2.1.0-2+deb8u6 CVE ID : CVE-2018-6616 CVE-2018-14423 Debian Bug : 904873, 889683

Multiple vulnerabilities have been discovered in openjpeg2, the open-source JPEG 2000 codec.

CVE-2018-6616

Excessive iteration in the opj_t1_encode_cblks function (openjp2/t1.c).
Remote attackers could leverage this vulnerability to cause a denial
of service via a crafted bmp file.

CVE-2018-14423

Division-by-zero vulnerabilities in the functions pi_next_pcrl,
pi_next_cprl, and pi_next_rpcl in (lib/openjp3d/pi.c). Remote attackers
could leverage this vulnerability to cause a denial of service
(application crash).

For Debian 8 "Jessie", these problems have been fixed in version 2.1.0-2+deb8u6.

We recommend that you upgrade your openjpeg2 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS