[SECURITY] [DLA 1297-1] simplesamlphp security update

2018-03-02T11:12:04
ID DEBIAN:DLA-1297-1:F0EE9
Type debian
Reporter Debian
Modified 2018-03-02T11:12:04

Description

Package : simplesamlphp Version : 1.9.2-1+deb7u3 CVE ID : CVE-2016-9814 CVE-2016-9955

Several vulnerabilities have been discovered in SimpleSAMLphp, a framework for authentication, primarily via the SAML protocol.

CVE-2016-9814 & CVE-2016-9955

An incorrect check of return values in the signature validation
utilities allowed an attacker to get invalid signatures accepted
as valid in the rare case of an error occurring during validation.

SSPSA-201802-01 (no CVE yet)

Critical signature validation vulnerability.

In addition this update adds a patch to solve excessive resource consumption in case of SimpleSAMLphp processing a large metadata file.

For Debian 7 "Wheezy", these problems have been fixed in version 1.9.2-1+deb7u3.

We recommend that you upgrade your simplesamlphp packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS