[SECURITY] [DLA 1134-1] sdl-image1.2 security update

2017-10-16T22:02:23
ID DEBIAN:DLA-1134-1:1ED94
Type debian
Reporter Debian
Modified 2017-10-16T22:02:23

Description

Package : sdl-image1.2 Version : 1.2.12-2+deb7u1 CVE ID : CVE-2017-2887 Debian Bug : #878267

It was discovered that there was a buffer overflow vulnerability in sdl-image1.2, an image loading library.

A specially crafted .xcf file could cause a stack-based buffer overflow resulting in potential code execution.

For Debian 7 "Wheezy", this issue has been fixed in sdl-image1.2 version 1.2.12-2+deb7u1.

We recommend that you upgrade your sdl-image1.2 packages.

Regards,


  ,''`.
 : :'  :     Chris Lamb
 `. `'`      lamby@debian.org / chris-lamb.co.uk
   `-